Elements XXL 2.50

Discussions about ElementsXXL, LayersXXL and ActionsXXL
tgv
Plugin Power User
Plugin Power User
Posts: 11
Joined: Fri Oct 03, 2014 8:55 am

Elements XXL 2.50

Postby tgv » Fri Oct 03, 2014 1:17 pm

curves.jpg
curves.jpg (42.6 KiB) Viewed 10094 times
Hello,
question from a user using Elements 13 on W64:
when using curves, "auto" does not work.

regards, tg

HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3331
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Re: Elements XXL 2.50

Postby HaraldHeim » Fri Oct 03, 2014 5:24 pm

Right, it seems the Auto button (as well as the corresponding Options button) of the Curves dialog does not work in Photoshop Elements 13 anymore. It works in Photoshop Elements 11 and 12, so Adobe has disabled it in the latest version.

However, you can trigger the same function from the Levels (Tonwertkorrektur) dialog or use one of the Auto menu items at the top of the Enhance (Überarbeiten) menu.

Photoshop Elements 13 misses two other dialogs, which had to be reprogrammed for ElementsXXL 2.50. So I am not surprised about this limitation. A future version of ElementsXXL will have its own more advanced Curves dialog.

tgv
Plugin Power User
Plugin Power User
Posts: 11
Joined: Fri Oct 03, 2014 8:55 am

Re: Elements XXL 2.50

Postby tgv » Fri Oct 03, 2014 6:31 pm

Harald, thank you for the hint!
Nevertheless, Tonwertkorrektur is kinda crippled in Elements. No possibility to set any preferences. Or did I miss anything?
Additionally, color-shifting after applying Tonwertkorrektur is a problem for me.
Auto-Kontrast has to be used, but I have very limited influence on the behavior.

regards - tg

HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3331
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Re: Elements XXL 2.50

Postby HaraldHeim » Sat Oct 04, 2014 12:17 pm

Right, the Levels dialog does not have an Options button, so there seems to be no way to adjust the behavior of the Auto feature in Photoshop Elements 13.

I cannot think of any quick workaround at the moment. The Auto functionality could be reprogrammed in ElementsXXL (which will have to be done for the own Curves dialog), but you have to live with the limitation for now. Sorry.

tgv
Plugin Power User
Plugin Power User
Posts: 11
Joined: Fri Oct 03, 2014 8:55 am

Re: Elements XXL 2.50

Postby tgv » Wed Dec 31, 2014 5:34 pm

Just having tested version 2.51; the Crash under win 7 64bit / PSE 13 occurs again.
nothing has changed for me.
kind regards, Guenther

HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3331
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Re: Elements XXL 2.50

Postby HaraldHeim » Wed Dec 31, 2014 6:55 pm

Which crash? Please explain.

macay
Plugin Power User
Plugin Power User
Posts: 7
Joined: Tue Dec 31, 2013 9:20 pm

Re: Elements XXL 2.50 - curves dialogues

Postby macay » Sat Jan 03, 2015 1:40 am

The Auto and Options buttons in Curves dialogues still work when editing separate channels (Red, Blue or Green) or two channels combinations. It would appear that it is the RGB mix that is affected - whether the Curves dialogue is opened directly via Ctrl+M or as an adjustment layer. (Opening a curve adjustment layer always reverts channels to RGB, anyway). Could this help to explain/resolve the issue?

Couple of other small things related to curve editing:
1. In v. 2.51 the names of two channels combos are truncated to the first colour in the drop down menus under Image>Channels. Thus "Red + Blue" appears as Red; "Red + Green" also as Red, and "Green + Blue" as Green. It was OK in v. 2.50.
2. Using the scrubber feature in the Curves dialogue window, i.e. clicking on the hand symbol and dragging in the image tends to crash PSE 13, at least on my machine.

Best regards,

mc

HaraldHeim
Plugin Guru
Plugin Guru
Posts: 3331
Joined: Fri Mar 08, 2002 1:00 am
Location: The Plugin Site
Contact:

Re: Elements XXL 2.50

Postby HaraldHeim » Sat Jan 03, 2015 3:14 pm

1. Right, when only selecting one or two channels in PSE 13 on the Image > Channels sub menu, the Auto and Options buttons on the Curves dialog work. So this indicates even more that it is a bug in PSE 13 as they do not work with three channels selected.

2. The "Red + Green" problem only seems to happen in non-English versions of PSE. I will fix it.

3. I do not get a crash with the scrubber tool here. In either case there would be no alternative other than deactivating the scrubber icon. But as it does not seem to crash always, I will leave it as it is.


Return to “ElementsXXL / LayersXXL / ActionsXXL”

Who is online

Users browsing this forum: No registered users and 2 guests